]> sjero.net Git - wget/blob - util/wget.spec
[svn] Use test ! -f foo instead of ! test -f foo.
[wget] / util / wget.spec
1 Name: wget
2 Version: 1.7
3 Release: 1
4 Copyright: GPL
5 Source: ftp://ftp.gnu.org/gnu/wget/wget-%{version}.tar.gz 
6 Url: http://sunsite.dk/wget/
7 Provides: webclient
8 Prereq: /sbin/install-info
9 BuildRoot: /var/tmp/%{name}-root
10
11 Group: Applications/Internet
12 Group(cs): Aplikace/Internet
13 Summary: A utility for retrieving files using the HTTP or FTP protocols.
14 Summary(cs): Nástroj pro stahování souborù pomocí protokolù HTTP nebo FTP.
15
16 %description
17 GNU Wget is a free network utility to retrieve files from the World
18 Wide Web using HTTP and FTP protocols. It works non-interactively,
19 thus enabling work in the background, after having logged off.
20 Wget supports recursive retrieval of HTML pages, as well as FTP sites.
21 Wget supports proxy servers, which can lighten the network load, speed
22 up retrieval and provide access behind firewalls.
23
24 It works exceedingly well also on slow or unstable connections,
25 keeping getting the document until it is fully retrieved. Re-getting
26 files from where it left off works on servers (both HTTP and FTP) that
27 support it. Matching of wildcards and recursive mirroring of
28 directories are available when retrieving via FTP.  Both HTTP and FTP
29 retrievals can be time-stamped, thus Wget can see if the remote file
30 has changed since last retrieval and automatically retrieve the new
31 version if it has.
32
33 Install wget if you need to retrieve large numbers of files with HTTP or
34 FTP, or if you need a utility for mirroring web sites or FTP directories.
35
36 %description -l cs
37
38
39 %prep
40 %setup -q
41
42 %build
43 %configure --sysconfdir=/etc
44 make
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %makeinstall
49 gzip $RPM_BUILD_ROOT%{_infodir}/*
50
51 %post
52 /sbin/install-info %{_infodir}/wget.info.gz %{_infodir}/dir
53
54 %preun
55 if [ "$1" = 0 ]; then
56     /sbin/install-info --delete %{_infodir}/wget.info.gz %{_infodir}/dir
57 fi
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(-,root,root)
64 %doc AUTHORS MAILING-LIST NEWS README INSTALL doc/ChangeLog doc/sample.wgetrc
65 %config /etc/wgetrc
66 %{_bindir}/wget
67 %{_infodir}/*
68 /usr/share/locale/*/LC_MESSAGES/*
69
70 %changelog
71 * Wed Jan  3 2001 Jan Prikryl <prikryl@cg.tuwien.ac.at>
72 - preliminary version for 1.7
73 - removed all RedHat patches from 1.5.3 for this moment
74
75 * Tue Aug  1 2000 Bill Nottingham <notting@redhat.com>
76 - setlocale for LC_CTYPE too, or else all the translations think their
77   characters are unprintable.
78
79 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
80 - automatic rebuild
81
82 * Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
83 - build in new environment
84
85 * Mon Jun  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
86 - FHS compliance
87
88 * Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
89 - handle compressed man pages
90
91 * Thu Aug 26 1999 Jeff Johnson <jbj@redhat.com>
92 - don't permit chmod 777 on symlinks (#4725).
93
94 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com> 
95 - auto rebuild in the new build environment (release 4)
96
97 * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
98 - build for 6.0 tree
99 - add Provides
100
101 * Sat Oct 10 1998 Cristian Gafton <gafton@redhat.com>
102 - strip binaries
103 - version 1.5.3
104
105 * Sat Jun 27 1998 Jeff Johnson <jbj@redhat.com>
106 - updated to 1.5.2
107
108 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
109 - modified group to Applications/Networking
110
111 * Wed Apr 22 1998 Cristian Gafton <gafton@redhat.com>
112 - upgraded to 1.5.0
113 - they removed the man page from the distribution (Duh!) and I added it back
114   from 1.4.5. Hey, removing the man page is DUMB!
115
116 * Fri Nov 14 1997 Cristian Gafton <gafton@redhat.com>
117 - first build against glibc