]> sjero.net Git - wget/blob - util/wget.spec
[svn] hniksic@iskon.hr -> hniksic@arsdigita.com
[wget] / util / wget.spec
1 Summary: A command-line client to download WWW/FTP documents with optional recursion.
2 Name: wget
3 %define version 1.4.5
4 Version: %{version}
5 Release: 3
6 Source: ftp://prep.ai.mit.edu/pub/gnu/wget-1.4.5.tar.gz
7 Group: Applications/Networking
8 Copyright: GPL
9 Buildroot: /var/tmp/wget-root
10 Packager: Jeff Johnson <jbj@jbj.org>
11
12 %description
13 GNU Wget is a freely available network utility to retrieve files from
14 the World Wide Web, using HTTP (Hyper Text Transfer Protocol) and
15 FTP (File Transfer Protocol), the two most widely used Internet
16 protocols.
17
18 %prep
19 %setup
20
21 %build
22 ./configure --prefix=/usr --sysconfdir=/etc
23 make
24
25 %install
26 rm -rf $RPM_BUILD_ROOT
27
28 make prefix=$RPM_BUILD_ROOT/usr sysconfdir=$RPM_BUILD_ROOT/etc INSTALL_PROGRAM="install -s" install
29
30 gzip -9nf $RPM_BUILD_ROOT/usr/info/wget*
31
32 %post
33
34 /sbin/install-info /usr/info/wget.info.gz /usr/info/dir --entry="* wget: (wget).          GNU Wget Manual."
35
36 %preun
37
38 if [ $1 = 0 ]; then
39         /sbin/install-info --delete /usr/info/wget.info.gz /usr/info/dir --entry="* wget: (wget).          GNU Wget Manual."
40 fi
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %doc README NEWS AUTHORS COPYING INSTALL MACHINES MAILING-LIST
47 /usr/bin/wget
48 /etc/wgetrc
49 /usr/info/wget*
50 /usr/man/man1/wget.1
51
52 %changelog
53
54 * Thu Feb 26 1998 Jeff Johnson <jbj@jbj.org>
55
56 - Simplify previous contrib version.
57