]> sjero.net Git - linphone/blobdiff - tools/Makefile.am
Aac-eld add missing header according to RFC3640 3.3.6
[linphone] / tools / Makefile.am
index e906e29b07f02befd70ff1b7c7343ca0080ef6c5..a93d809f142f0f38d6e4b4b0b43cff2269c3eb44 100644 (file)
@@ -11,31 +11,50 @@ COMMON_CFLAGS=\
        $(STRICT_OPTIONS) \
        $(LIBXML2_CFLAGS) 
 
+EXTRA_DIST=xml2lpc_jni.cc lpc2xml_jni.cc
+
 if BUILD_TOOLS
 
-lib_LTLIBRARIES=libxml2lpc.la
+lib_LTLIBRARIES=libxml2lpc.la liblpc2xml.la
 
 libxml2lpc_la_SOURCES=\
        xml2lpc.c \
        xml2lpc.h
 
+liblpc2xml_la_SOURCES=\
+       lpc2xml.c \
+       lpc2xml.h
+
 libxml2lpc_la_CFLAGS=$(COMMON_CFLAGS)
 libxml2lpc_la_LIBADD=\
        $(top_builddir)/coreapi/liblinphone.la \
        $(LIBXML2_LIBS) 
 
+liblpc2xml_la_CFLAGS=$(COMMON_CFLAGS)
+liblpc2xml_la_LIBADD=\
+       $(top_builddir)/coreapi/liblinphone.la \
+       $(LIBXML2_LIBS) 
+
 libxml2lpc_la_LDFLAGS=-no-undefined
+liblpc2xml_la_LDFLAGS=-no-undefined
 
-bin_PROGRAMS=xml2lpc_test
+bin_PROGRAMS=xml2lpc_test lpc2xml_test
 
 xml2lpc_test_SOURCES=\
        xml2lpc_test.c
 
+lpc2xml_test_SOURCES=\
+       lpc2xml_test.c
+
 xml2lpc_test_CFLAGS=$(COMMON_CFLAGS)
 xml2lpc_test_LDADD=\
        $(top_builddir)/coreapi/liblinphone.la \
        libxml2lpc.la 
 
+lpc2xml_test_CFLAGS=$(COMMON_CFLAGS)
+lpc2xml_test_LDADD=\
+       $(top_builddir)/coreapi/liblinphone.la \
+       liblpc2xml.la 
 endif