]> sjero.net Git - wget/blobdiff - tests/Makefile.am
Use the gnulib md5 module.
[wget] / tests / Makefile.am
index f1ae27ef14aa4e96965c4c0c7ceb97cfc964c36d..e2deb980f68a4344911eb9b60daaddc6ada23c1e 100644 (file)
@@ -1,6 +1,7 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation,
+# Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -33,6 +34,8 @@
 PERL     = perl
 PERLRUN = $(PERL) -I$(srcdir)
 
+LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBICONV@ @LIBINTL@ @W32LIBS@ @LIBS@
+
 .PHONY: test run-unit-tests run-px-tests
 
 check-local: test
@@ -50,9 +53,6 @@ test: ../src/wget$(EXEEXT) run-unit-tests run-px-tests
 ../lib/libgnu.a:
        cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
 
-../md5/libmd5.a:
-       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
-
 run-unit-tests: unit-tests$(EXEEXT) ../src/libunittest.a
        ./unit-tests$(EXEEXT)
 
@@ -84,6 +84,8 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
              Test-HTTP-Content-Disposition-1.px \
              Test-HTTP-Content-Disposition-2.px \
              Test-HTTP-Content-Disposition.px \
+             Test-i-ftp.px \
+             Test-i-http.px \
              Test-idn-headers.px \
              Test-idn-meta.px \
              Test-idn-cmd.px \
@@ -129,7 +131,6 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
 
 check_PROGRAMS = unit-tests
 unit_tests_SOURCES =
-LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@ \
-    @MD5_LDADD@
+LDADD = ../src/libunittest.a ../lib/libgnu.a $(LIBS)
 
 CLEANFILES = *~ *.bak core core.[0-9]*