]> sjero.net Git - wget/blobdiff - tests/Makefile.am
Updated config.guess, config.sub, install.sh.
[wget] / tests / Makefile.am
index 27f9adaa01ba761f616bc4a184a7282c969bb52d..ca2f3502ed535fede8e0f64726b7d9b8e4b286f2 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -42,26 +42,83 @@ test: ../src/wget$(EXEEXT) run-unit-tests run-px-tests
 ../src/wget$(EXEEXT):
        cd ../src && $(MAKE) $(AM_MAKEFLAGS)
 
+../src/libunittest.a:
+       cd ../src && $(MAKE) $(AM_MAKEFLAGS) libunittest.a
+
+../lib/libgnu.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
+../md5/libmd5.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
 run-unit-tests: unit-tests$(EXEEXT)
        ./unit-tests$(EXEEXT)
 
-run-px-tests: WgetTest.pm
-       ./run-px $(top_srcdir)
+run-px-tests: WgetTest.pm ../src/wget$(EXEEXT)
+       $(srcdir)/run-px $(top_srcdir)
 
 EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
-            Test-auth-basic.px Test-c-full.px Test-c-partial.px \
-            Test-c.px Test-E-k-K.px Test-E-k.px Test-ftp.px \
-            Test-HTTP-Content-Disposition-1.px \
-            Test-HTTP-Content-Disposition-2.px \
-            Test-HTTP-Content-Disposition.px \
-            Test-N-current.px Test-N-old.px Test-nonexisting-quiet.px \
-            Test-noop.px Test-np.px Test-N.px \
-            Test-O-nonexisting.px Test-O.px \
-            Test-Restrict-Lowercase.px Test-Restrict-Uppercase.px \
-            Test--spider-fail.px Test--spider.px Test--spider-r.px
+             Test-auth-basic.px \
+             Test-auth-no-challenge.px \
+             Test-auth-no-challenge-url.px \
+             Test-c-full.px \
+             Test-c-partial.px \
+             Test-c.px \
+             Test-c-shorter.px \
+             Test-E-k-K.px \
+             Test-E-k.px \
+             Test-ftp.px \
+             Test-ftp-iri.px \
+             Test-ftp-iri-fallback.px \
+             Test-ftp-iri-recursive.px \
+             Test-ftp-iri-disabled.px \
+             Test-HTTP-Content-Disposition-1.px \
+             Test-HTTP-Content-Disposition-2.px \
+             Test-HTTP-Content-Disposition.px \
+             Test-idn-headers.px \
+             Test-idn-meta.px \
+             Test-idn-cmd.px \
+             Test-idn-robots.px \
+             Test-iri.px \
+             Test-iri-percent.px \
+             Test-iri-disabled.px \
+             Test-iri-forced-remote.px \
+             Test-iri-list.px \
+             Test-meta-robots.px \
+             Test-N-current.px \
+             Test-N-HTTP-Content-Disposition.px \
+             Test-N--no-content-disposition.px \
+             Test-N--no-content-disposition-trivial.px \
+             Test-N-no-info.px \
+             Test--no-content-disposition.px \
+             Test--no-content-disposition-trivial.px \
+             Test-N-old.px \
+             Test-nonexisting-quiet.px \
+             Test-noop.px \
+             Test-np.px \
+             Test-N.px \
+             Test-N-smaller.px \
+             Test-O-HTTP-Content-Disposition.px \
+             Test-O-nc.px \
+             Test-O--no-content-disposition.px \
+             Test-O--no-content-disposition-trivial.px \
+             Test-O-nonexisting.px \
+             Test-O.px \
+             Test-proxied-https-auth.px \
+             Test-proxy-auth-basic.px \
+             Test-Restrict-Lowercase.px \
+             Test-Restrict-Uppercase.px \
+             Test--spider-fail.px \
+             Test--spider.px \
+             Test--spider-r-HTTP-Content-Disposition.px \
+             Test--spider-r--no-content-disposition.px \
+             Test--spider-r--no-content-disposition-trivial.px \
+             Test--spider-r.px \
+             run-px certs
 
 check_PROGRAMS = unit-tests
 unit_tests_SOURCES = 
+#unit-tests: ../src/libunittest.a ../lib/libgnu.a
 LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@ \
         @MD5_LDADD@