]> sjero.net Git - wget/blobdiff - tests/Makefile.am
Merge SFLC licensing changes for OpenSSL with tip.
[wget] / tests / Makefile.am
index c8f6e833bc862a9b0fee9851dcaf3409b6a8ddc6..ad61e46aeeb58dc61bd74af8b75f259fc69e1de0 100644 (file)
 # You should have received a copy of the GNU General Public License
 # along with Wget.  If not, see <http://www.gnu.org/licenses/>.
 
-# In addition, as a special exception, the Free Software Foundation
-# gives permission to link the code of its release of Wget with the
-# OpenSSL project's "OpenSSL" library (or with modified versions of it
-# that use the same license as the "OpenSSL" library), and distribute
-# the linked executables.  You must obey the GNU General Public License
-# in all respects for all of the code used other than "OpenSSL".  If you
-# modify this file, you may extend this exception to your version of the
-# file, but you are not obligated to do so.  If you do not wish to do
-# so, delete this exception statement from your version.
+# Additional permission under GNU GPL version 3 section 7
+
+# If you modify this program, or any covered work, by linking or
+# combining it with the OpenSSL project's OpenSSL library (or a
+# modified version of that library), containing parts covered by the
+# terms of the OpenSSL or SSLeay licenses, the Free Software Foundation
+# grants you additional permission to convey the resulting work.
+# Corresponding Source for a non-source form of such a combination
+# shall include the source code for the parts of OpenSSL used as well
+# as that of the covered work.
 
 #
 # Version: @VERSION@
@@ -36,7 +37,7 @@ PERLRUN = $(PERL) -I$(srcdir)
 
 check-local: test
 
-test: ../src/wget$(EXEEXT) run-unit-tests run-px-tests
+test: ../src/wget$(EXEEXT) run-unit-tests #run-px-tests
 
 ../src/wget$(EXEEXT):
        cd ../src && $(MAKE) $(AM_MAKEFLAGS)
@@ -98,6 +99,6 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
 
 check_PROGRAMS = unit-tests
 unit_tests_SOURCES = 
-LDADD = ../src/libunittest.a
+LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@
 
 CLEANFILES = *~ *.bak core core.[0-9]*