]> sjero.net Git - wget/blobdiff - tests/Makefile.am
Allow proxied-https-auth test to function when building outside of source dir.
[wget] / tests / Makefile.am
index 853698285a7cf6ba7eb8b293056bf1fbf3f168e9..aa8dd53ce5c9e1ca0159894a443cc1b9e72c8c2b 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -37,16 +37,25 @@ PERLRUN = $(PERL) -I$(srcdir)
 
 check-local: test
 
-test: ../src/wget$(EXEEXT) run-unit-tests #run-px-tests
+test: ../src/wget$(EXEEXT) run-unit-tests run-px-tests
 
 ../src/wget$(EXEEXT):
        cd ../src && $(MAKE) $(AM_MAKEFLAGS)
 
+../src/libunittest.a:
+       cd ../src && $(MAKE) $(AM_MAKEFLAGS) libunittest.a
+
+../lib/libgnu.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
+../md5/libmd5.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
 run-unit-tests: unit-tests$(EXEEXT)
        ./unit-tests$(EXEEXT)
 
-run-px-tests: WgetTest.pm
-       ./run-px $(top_srcdir)
+run-px-tests: WgetTest.pm ../src/wget$(EXEEXT)
+       $(srcdir)/run-px $(top_srcdir)
 
 EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
             Test-auth-basic.px Test-c-full.px Test-c-partial.px \
@@ -62,6 +71,7 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
 
 check_PROGRAMS = unit-tests
 unit_tests_SOURCES = 
+#unit-tests: ../src/libunittest.a ../lib/libgnu.a
 LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@ \
         @MD5_LDADD@