]> sjero.net Git - wget/blobdiff - tests/Makefile.am
tests: add missing files to Makefile.am
[wget] / tests / Makefile.am
index 51d3f870f42f073765cc75025c3264d94d0f7bc4..76fe2f09b020a8249d3c1d4ea615f66cf18ec344 100644 (file)
@@ -1,6 +1,7 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # You should have received a copy of the GNU General Public License
 # along with Wget.  If not, see <http://www.gnu.org/licenses/>.
 
-# In addition, as a special exception, the Free Software Foundation
-# gives permission to link the code of its release of Wget with the
-# OpenSSL project's "OpenSSL" library (or with modified versions of it
-# that use the same license as the "OpenSSL" library), and distribute
-# the linked executables.  You must obey the GNU General Public License
-# in all respects for all of the code used other than "OpenSSL".  If you
-# modify this file, you may extend this exception to your version of the
-# file, but you are not obligated to do so.  If you do not wish to do
-# so, delete this exception statement from your version.
+# Additional permission under GNU GPL version 3 section 7
+
+# If you modify this program, or any covered work, by linking or
+# combining it with the OpenSSL project's OpenSSL library (or a
+# modified version of that library), containing parts covered by the
+# terms of the OpenSSL or SSLeay licenses, the Free Software Foundation
+# grants you additional permission to convey the resulting work.
+# Corresponding Source for a non-source form of such a combination
+# shall include the source code for the parts of OpenSSL used as well
+# as that of the covered work.
 
 #
 # Version: @VERSION@
 PERL     = perl
 PERLRUN = $(PERL) -I$(srcdir)
 
+LIBS     = @LIBICONV@ @LIBINTL@ @LIBS@ $(LIB_CLOCK_GETTIME)
+
 .PHONY: test run-unit-tests run-px-tests
 
 check-local: test
 
-test: ../src/wget$(EXEEXT) run-unit-tests #run-px-tests
+test: ../src/wget$(EXEEXT) run-unit-tests run-px-tests
 
 ../src/wget$(EXEEXT):
        cd ../src && $(MAKE) $(AM_MAKEFLAGS)
 
-run-unit-tests: unit-tests$(EXEEXT)
+# Make libunittest "PHONY" so we're always sure we're up-to-date.
+.PHONY: ../src/libunittest.a
+../src/libunittest.a:
+       cd ../src && $(MAKE) $(AM_MAKEFLAGS) libunittest.a
+
+../lib/libgnu.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
+run-unit-tests: unit-tests$(EXEEXT) ../src/libunittest.a
        ./unit-tests$(EXEEXT)
 
-run-px-tests: WgetTest.pm
-       $(PERLRUN) $(srcdir)/Test-auth-basic.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-c-full.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-c-partial.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-c.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-E-k-K.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-E-k.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-ftp.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-HTTP-Content-Disposition-1.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-HTTP-Content-Disposition-2.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-HTTP-Content-Disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-N-current-HTTP-CD.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-N-current.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-N-HTTP-Content-Disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-N--no-content-disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-N--no-content-disposition-trivial.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--no-content-disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--no-content-disposition-trivial.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-N-old.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-nonexisting-quiet.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-noop.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-np.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-N.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-O-HTTP-Content-Disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-O--no-content-disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-O--no-content-disposition-trivial.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-O-nonexisting.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-O.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-Restrict-Lowercase.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test-Restrict-Uppercase.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider-fail.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider-HTTP-Content-Disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider--no-content-disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider--no-content-disposition-trivial.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider-r-HTTP-Content-Disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider-r--no-content-disposition.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider-r--no-content-disposition-trivial.px && echo && echo
-       $(PERLRUN) $(srcdir)/Test--spider-r.px && echo && echo
+run-px-tests: WgetTest.pm ../src/wget$(EXEEXT)
+       $(srcdir)/run-px $(top_srcdir)
 
 EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
-            Test-auth-basic.px Test-c-full.px Test-c-partial.px \
-            Test-c.px Test-E-k-K.px Test-E-k.px Test-ftp.px \
-            Test-HTTP-Content-Disposition-1.px \
-            Test-HTTP-Content-Disposition-2.px \
-            Test-HTTP-Content-Disposition.px \
-            Test-N-current.px Test-N-old.px Test-nonexisting-quiet.px \
-            Test-noop.px Test-np.px Test-N.px \
-            Test-O-nonexisting.px Test-O.px \
-            Test-Restrict-Lowercase.px Test-Restrict-Uppercase.px \
-            Test--spider-fail.px Test--spider.px Test--spider-r.px
+             WgetFeature.pm WgetFeature.cfg \
+             Test-auth-basic.px \
+             Test-auth-no-challenge.px \
+             Test-auth-no-challenge-url.px \
+             Test-auth-with-content-disposition.px \
+             Test-auth-retcode.px \
+             Test-c-full.px \
+             Test-c-partial.px \
+             Test-c.px \
+             Test-c-shorter.px \
+             Test-cookies.px \
+             Test-cookies-401.px \
+             Test-E-k-K.px \
+             Test-E-k.px \
+             Test-ftp.px \
+             Test-ftp-pasv-fail.px \
+             Test-ftp-bad-list.px \
+             Test-ftp-recursive.px \
+             Test-ftp-iri.px \
+             Test-ftp-iri-fallback.px \
+             Test-ftp-iri-recursive.px \
+             Test-ftp-iri-disabled.px \
+             Test-ftp-list-Multinet.px \
+             Test-ftp-list-Unknown.px \
+             Test-ftp-list-Unknown-a.px \
+             Test-ftp-list-Unknown-hidden.px \
+             Test-ftp-list-Unknown-list-a-fails.px \
+             Test-ftp-list-UNIX-hidden.px \
+             Test-ftp--start-pos.px \
+             Test-HTTP-Content-Disposition-1.px \
+             Test-HTTP-Content-Disposition-2.px \
+             Test-HTTP-Content-Disposition.px \
+             Test-i-ftp.px \
+             Test-i-http.px \
+             Test-idn-headers.px \
+             Test-idn-meta.px \
+             Test-idn-cmd.px \
+             Test-idn-cmd-utf8.px \
+             Test-idn-robots.px \
+             Test-idn-robots-utf8.px \
+             Test-iri.px \
+             Test-iri-percent.px \
+             Test-iri-disabled.px \
+             Test-iri-forced-remote.px \
+             Test-iri-list.px \
+             Test-k.px \
+             Test-meta-robots.px \
+             Test-N-current.px \
+             Test-N-HTTP-Content-Disposition.px \
+             Test-N--no-content-disposition.px \
+             Test-N--no-content-disposition-trivial.px \
+             Test-N-no-info.px \
+             Test--no-content-disposition.px \
+             Test--no-content-disposition-trivial.px \
+             Test-N-old.px \
+             Test-nonexisting-quiet.px \
+             Test-noop.px \
+             Test-np.px \
+             Test-N.px \
+             Test-N-smaller.px \
+             Test-O-HTTP-Content-Disposition.px \
+             Test-O-nc.px \
+             Test-O--no-content-disposition.px \
+             Test-O--no-content-disposition-trivial.px \
+             Test-O-nonexisting.px \
+             Test-O.px \
+             Test--post-file.px \
+             Test-proxied-https-auth.px \
+             Test-proxy-auth-basic.px \
+             Test-restrict-ascii.px \
+             Test-Restrict-Lowercase.px \
+             Test-Restrict-Uppercase.px \
+            Test-stdouterr.px \
+             Test--spider-fail.px \
+             Test--spider.px \
+             Test--spider-r-HTTP-Content-Disposition.px \
+             Test--spider-r--no-content-disposition.px \
+             Test--spider-r--no-content-disposition-trivial.px \
+             Test--spider-r.px \
+             Test--start-pos.px \
+             Test--start-pos--continue.px \
+             Test--httpsonly-r.px \
+             run-px certs
 
 check_PROGRAMS = unit-tests
-unit_tests_SOURCES = 
-LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@
+unit_tests_SOURCES =
+LDADD = ../src/libunittest.a ../lib/libgnu.a $(LIBS)
 
 CLEANFILES = *~ *.bak core core.[0-9]*