]> sjero.net Git - wget/blobdiff - tests/Makefile.am
Fix unit tests build in a VPATH.
[wget] / tests / Makefile.am
index e002b3210743fabb068854864c2b01490935858a..75d9660e31a064912120413ffdf506a18322af8b 100644 (file)
@@ -33,6 +33,8 @@
 PERL     = perl
 PERLRUN = $(PERL) -I$(srcdir)
 
+LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBICONV@ @LIBINTL@ @W32LIBS@ @LIBS@
+
 .PHONY: test run-unit-tests run-px-tests
 
 check-local: test
@@ -84,6 +86,7 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
              Test-HTTP-Content-Disposition-1.px \
              Test-HTTP-Content-Disposition-2.px \
              Test-HTTP-Content-Disposition.px \
+             Test-i-ftp.px \
              Test-i-http.px \
              Test-idn-headers.px \
              Test-idn-meta.px \
@@ -130,7 +133,6 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
 
 check_PROGRAMS = unit-tests
 unit_tests_SOURCES =
-LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@ \
-    @MD5_LDADD@
+LDADD = ../src/libunittest.a ../lib/libgnu.a @MD5_LDADD@ $(LIBS)
 
 CLEANFILES = *~ *.bak core core.[0-9]*