]> sjero.net Git - wget/blobdiff - tests/Makefile.am
Authentication through proxy.
[wget] / tests / Makefile.am
index ad61e46aeeb58dc61bd74af8b75f259fc69e1de0..224cb9cc56fbdb8d4c7b44c03003f5628e388be0 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -46,6 +46,7 @@ run-unit-tests: unit-tests$(EXEEXT)
        ./unit-tests$(EXEEXT)
 
 run-px-tests: WgetTest.pm
+       $(PERLRUN) $(srcdir)/Test-proxy-auth-basic.px && echo && echo
        $(PERLRUN) $(srcdir)/Test-auth-basic.px && echo && echo
        $(PERLRUN) $(srcdir)/Test-c-full.px && echo && echo
        $(PERLRUN) $(srcdir)/Test-c-partial.px && echo && echo
@@ -99,6 +100,7 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
 
 check_PROGRAMS = unit-tests
 unit_tests_SOURCES = 
-LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@
+LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@ \
+        @MD5_LDADD@
 
 CLEANFILES = *~ *.bak core core.[0-9]*