]> sjero.net Git - wget/blobdiff - tests/Makefile.am
Authentication through proxy.
[wget] / tests / Makefile.am
index 45afdfa9216d7e5cb086cb11fdb8de67cf9ce692..224cb9cc56fbdb8d4c7b44c03003f5628e388be0 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # You should have received a copy of the GNU General Public License
 # along with Wget.  If not, see <http://www.gnu.org/licenses/>.
 
-# In addition, as a special exception, the Free Software Foundation
-# gives permission to link the code of its release of Wget with the
-# OpenSSL project's "OpenSSL" library (or with modified versions of it
-# that use the same license as the "OpenSSL" library), and distribute
-# the linked executables.  You must obey the GNU General Public License
-# in all respects for all of the code used other than "OpenSSL".  If you
-# modify this file, you may extend this exception to your version of the
-# file, but you are not obligated to do so.  If you do not wish to do
-# so, delete this exception statement from your version.
+# Additional permission under GNU GPL version 3 section 7
+
+# If you modify this program, or any covered work, by linking or
+# combining it with the OpenSSL project's OpenSSL library (or a
+# modified version of that library), containing parts covered by the
+# terms of the OpenSSL or SSLeay licenses, the Free Software Foundation
+# grants you additional permission to convey the resulting work.
+# Corresponding Source for a non-source form of such a combination
+# shall include the source code for the parts of OpenSSL used as well
+# as that of the covered work.
 
 #
 # Version: @VERSION@
@@ -45,6 +46,7 @@ run-unit-tests: unit-tests$(EXEEXT)
        ./unit-tests$(EXEEXT)
 
 run-px-tests: WgetTest.pm
+       $(PERLRUN) $(srcdir)/Test-proxy-auth-basic.px && echo && echo
        $(PERLRUN) $(srcdir)/Test-auth-basic.px && echo && echo
        $(PERLRUN) $(srcdir)/Test-c-full.px && echo && echo
        $(PERLRUN) $(srcdir)/Test-c-partial.px && echo && echo
@@ -98,6 +100,7 @@ EXTRA_DIST = FTPServer.pm FTPTest.pm HTTPServer.pm HTTPTest.pm \
 
 check_PROGRAMS = unit-tests
 unit_tests_SOURCES = 
-LDADD = ../src/libunittest.a @LIBSSL@ @LIBGNUTLS@
+LDADD = ../src/libunittest.a ../lib/libgnu.a @LIBSSL@ @LIBGNUTLS@ \
+        @MD5_LDADD@
 
 CLEANFILES = *~ *.bak core core.[0-9]*