]> sjero.net Git - wget/blobdiff - src/Makefile.am
Eschew config-post.h.
[wget] / src / Makefile.am
index dcc19c816d0f31cf7f1afdf0046b045986a80a26..f1049efa40e62a4979859175e8d1c3812423be8f 100644 (file)
@@ -37,30 +37,26 @@ bin_PROGRAMS = wget
 wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c  \
               ftp-ls.c hash.c host.c html-parse.c html-url.c http.c    \
               init.c log.c main.c netrc.c progress.c ptimer.c recur.c  \
-              res.c retr.c safe-ctype.c snprintf.c spider.c url.c      \
-              utils.c version.c xmalloc.c                              \
-              config-post.h connect.h convert.h cookies.h              \
-              ftp.h gen-md5.h getopt.h gnu-md5.h hash.h host.h html-parse.h \
+              res.c retr.c snprintf.c spider.c url.c   \
+              utils.c xmalloc.c                                \
+              connect.h convert.h cookies.h            \
+              ftp.h gen-md5.h hash.h host.h html-parse.h \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
-              options.h progress.h ptimer.h recur.h res.h retr.h safe-ctype.h \
+              options.h progress.h ptimer.h recur.h res.h retr.h \
               spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
+nodist_wget_SOURCES = version.c
 EXTRA_wget_SOURCES = mswindows.c
-LDADD = $(ALLOCA) $(LIBOBJS)
+LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a
+AM_CPPFLAGS = -I$(top_srcdir)/lib
 
-# version.c's not really _phony_, but it does need to be generated each run.
-.PHONY: version.c
-version.c: hg-id
-       printf '%s' 'const char *version_string = "@VERSION@' > $@
-       -HG_ID=$$(cat hg-id); [ "$$HG_ID" ] && printf '%s' " ($${HG_ID})" >> $@
-       printf '%s\n' '";' >> $@
-
-.INTERMEDIATE: hg-id
-hg-id:
-       -( hg id | cut -f 1 -d ' ' ) 2>/dev/null > $@
+version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
+       echo 'const char *version_string = "@VERSION@"' > $@
+       -hg log -r . --template='" ({node|short})"\n' 2>/dev/null >> $@
+       echo ';' >> $@
 
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h
 libunittest_a_CPPFLAGS = -DTESTING
 libunittest_a_LIBADD = $(ALLOCA) $(LIBOBJS)
 
-CLEANFILES = *~ *.bak core core.[0-9]*
+CLEANFILES = *~ *.bak core core.[0-9]* version.c