]> sjero.net Git - wget/blobdiff - src/Makefile.am
Add dependency for version.c on configure.ac.
[wget] / src / Makefile.am
index a225e8f692051ab597cd8001a82a643eee1e6afc..f0da4eee925a73f35bbba4c4fec8e55b6625f794 100644 (file)
@@ -36,7 +36,7 @@ endif
 
 # The following line is losing on some versions of make!
 DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBINTL@ @LIBS@
+LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBICONV@ @LIBINTL@ @LIBS@
 
 bin_PROGRAMS = wget
 wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                \
@@ -49,9 +49,9 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c               \
               ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h      \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
               options.h progress.h ptimer.h recur.h res.h retr.h         \
-              spider.h ssl.h sysdep.h url.h utils.h wget.h
+              spider.h ssl.h sysdep.h url.h utils.h wget.h iri.h
 nodist_wget_SOURCES = build_info.c version.c
-EXTRA_wget_SOURCES = mswindows.c
+EXTRA_wget_SOURCES = mswindows.c iri.c
 LDADD = $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
 AM_CPPFLAGS = -I$(top_srcdir)/lib @MD5_CPPFLAGS@
 
@@ -65,7 +65,8 @@ build_info.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
        perl $(top_srcdir)/build_info.pl > $@
 
 ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
-version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
+version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am \
+    $(top_srcdir)/configure.ac
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@