]> sjero.net Git - wget/blobdiff - src/Makefile.am
Finish integration of libmd5.
[wget] / src / Makefile.am
index 709db8acf5e090b325192f2f6866d90626b3650a..e3816faea38734d37096ac5125e4ee38a53c2462 100644 (file)
 # You should have received a copy of the GNU General Public License
 # along with Wget.  If not, see <http://www.gnu.org/licenses/>.
 
-# In addition, as a special exception, the Free Software Foundation
-# gives permission to link the code of its release of Wget with the
-# OpenSSL project's "OpenSSL" library (or with modified versions of it
-# that use the same license as the "OpenSSL" library), and distribute
-# the linked executables.  You must obey the GNU General Public License
-# in all respects for all of the code used other than "OpenSSL".  If you
-# modify this file, you may extend this exception to your version of the
-# file, but you are not obligated to do so.  If you do not wish to do
-# so, delete this exception statement from your version.
+# Additional permission under GNU GPL version 3 section 7
+
+# If you modify this program, or any covered work, by linking or
+# combining it with the OpenSSL project's OpenSSL library (or a
+# modified version of that library), containing parts covered by the
+# terms of the OpenSSL or SSLeay licenses, the Free Software Foundation
+# grants you additional permission to convey the resulting work.
+# Corresponding Source for a non-source form of such a combination
+# shall include the source code for the parts of OpenSSL used as well
+# as that of the covered work.
 
 #
 # Version: @VERSION@
@@ -46,8 +47,8 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c \
               spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
 nodist_wget_SOURCES = version.c
 EXTRA_wget_SOURCES = mswindows.c
-LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a
-AM_CPPFLAGS = -I$(top_srcdir)/lib
+LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
+AM_CPPFLAGS = -I $(top_srcdir)/lib @MD5_CPPFLAGS@
 
 version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
        echo 'const char *version_string = "@VERSION@"' > $@