]> sjero.net Git - wget/blobdiff - src/Makefile.am
Adds build information to the --version command line option.
[wget] / src / Makefile.am
index d91ee764e92b1440c184f9dc1bcde66db64d8f7a..cafcc20c48326e26c5bc924d7edba2e91306cd7b 100644 (file)
@@ -35,25 +35,32 @@ DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(local
 LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBINTL@ @LIBS@
 
 bin_PROGRAMS = wget
-wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c  \
-              ftp-ls.c hash.c host.c html-parse.c html-url.c http.c    \
-              init.c log.c main.c netrc.c progress.c ptimer.c recur.c  \
-              res.c retr.c snprintf.c spider.c url.c   \
-              utils.c xmalloc.c                                \
-              connect.h convert.h cookies.h            \
-              ftp.h gen-md5.h hash.h host.h html-parse.h \
-              http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
-              options.h progress.h ptimer.h recur.h res.h retr.h \
+wget_SOURCES = build_info.c cmpt.c connect.c convert.c cookies.c ftp.c    \
+              ftp-basic.c ftp-ls.c hash.c host.c html-parse.c html-url.c \
+              http.c init.c log.c main.c netrc.c progress.c ptimer.c     \
+              recur.c res.c retr.c snprintf.c spider.c url.c             \
+              utils.c xmalloc.c                                          \
+              connect.h convert.h cookies.h                              \
+              ftp.h gen-md5.h hash.h host.h html-parse.h                 \
+              http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
+              options.h progress.h ptimer.h recur.h res.h retr.h         \
               spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
 nodist_wget_SOURCES = version.c
 EXTRA_wget_SOURCES = mswindows.c
 LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
 AM_CPPFLAGS = -I$(top_srcdir)/lib @MD5_CPPFLAGS@
 
+ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
 version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
-       echo 'const char *version_string = "@VERSION@"' > $@
-       -hg log -r . --template='" ({node|short})"\n' 2>/dev/null >> $@
+       echo '/* version.c */' > $@
+       echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
+       echo '' >> $@
+       echo -n 'char* version_string = "@VERSION@ ' >> $@
+       -hg log -r . --template=' ({node|short})"\n' 2>/dev/null >> $@
        echo ';' >> $@
+       echo 'char* compilation_string = "'$(COMPILE)'";' | $(ESCAPEQUOTE) >> $@
+       echo 'char* link_string = "'$(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+       $(AM_LDFLAGS) $(LDFLAGS) $(LIBS) $(wget_LDADD)'";' | $(ESCAPEQUOTE) >> $@
 
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h