]> sjero.net Git - wget/blobdiff - src/Makefile.am
Remove original getopt.[ch] in favor of gnulib's.
[wget] / src / Makefile.am
index dcc19c816d0f31cf7f1afdf0046b045986a80a26..c9f78f27392eb7602aea8e2c664aa674e1c6c0bf 100644 (file)
@@ -40,22 +40,21 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c       \
               res.c retr.c safe-ctype.c snprintf.c spider.c url.c      \
               utils.c version.c xmalloc.c                              \
               config-post.h connect.h convert.h cookies.h              \
-              ftp.h gen-md5.h getopt.h gnu-md5.h hash.h host.h html-parse.h \
+              ftp.h gen-md5.h gnu-md5.h hash.h host.h html-parse.h \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
               options.h progress.h ptimer.h recur.h res.h retr.h safe-ctype.h \
               spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
 EXTRA_wget_SOURCES = mswindows.c
 LDADD = $(ALLOCA) $(LIBOBJS)
 
-# version.c's not really _phony_, but it does need to be generated each run.
-.PHONY: version.c
 version.c: hg-id
        printf '%s' 'const char *version_string = "@VERSION@' > $@
        -HG_ID=$$(cat hg-id); [ "$$HG_ID" ] && printf '%s' " ($${HG_ID})" >> $@
        printf '%s\n' '";' >> $@
 
 .INTERMEDIATE: hg-id
-hg-id:
+.PHONY: hg-id
+hg-id: $(wget_SOURCES) $(LDADD)
        -( hg id | cut -f 1 -d ' ' ) 2>/dev/null > $@
 
 check_LIBRARIES = libunittest.a