]> sjero.net Git - wget/blobdiff - src/Makefile.am
Fix merge glitches, get it to build.
[wget] / src / Makefile.am
index 8d3270150c97d92e5d65849473379bbc2578944b..a29983a9db44e1a38c1d6ba1a81c88454ced3ef1 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -35,20 +35,22 @@ DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(local
 LIBS     = @LIBS@ @LIBSSL@ @LIBGNUTLS@ @LIBINTL@
 
 bin_PROGRAMS = wget
-wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c  \
+wget_SOURCES = cmpt.c connect.c convert.c cookies.c \
+              css.l css-url.c \
+              ftp.c ftp-basic.c \
               ftp-ls.c hash.c host.c html-parse.c html-url.c http.c    \
               init.c log.c main.c netrc.c progress.c ptimer.c recur.c  \
               res.c retr.c snprintf.c spider.c url.c   \
               utils.c xmalloc.c                                \
-              connect.h convert.h cookies.h            \
-              ftp.h gen-md5.h hash.h host.h html-parse.h \
+              css-url.h connect.h convert.h cookies.h \
+              ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
               options.h progress.h ptimer.h recur.h res.h retr.h \
               spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
 nodist_wget_SOURCES = version.c
 EXTRA_wget_SOURCES = mswindows.c
-LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a
-AM_CPPFLAGS = -I$(top_srcdir)/lib
+LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
+AM_CPPFLAGS = -I $(top_srcdir)/lib @MD5_CPPFLAGS@
 
 version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
        echo 'const char *version_string = "@VERSION@"' > $@