]> sjero.net Git - wget/blobdiff - src/Makefile.am
Don't require Perl for user builds.
[wget] / src / Makefile.am
index 16e4bcb0d87c4da64f55eaff7cc817942485583f..93930d14b6510d7316b620952096fc86129d959d 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # Version: @VERSION@
 #
 
+if IRI_IS_ENABLED
+IRI_OBJ = iri.c
+endif
+
 # The following line is losing on some versions of make!
 DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBINTL@ @LIBS@
+LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBICONV@ @LIBINTL@ @LIBS@
 
 bin_PROGRAMS = wget
-wget_SOURCES = build_info.c cmpt.c connect.c convert.c cookies.c ftp.c    \
+wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                \
               css.l css-url.c \
               ftp-basic.c ftp-ls.c hash.c host.c html-parse.c html-url.c \
               http.c init.c log.c main.c netrc.c progress.c ptimer.c     \
               recur.c res.c retr.c snprintf.c spider.c url.c             \
-              utils.c                                    \
-              css-url.h connect.h convert.h cookies.h \
+              utils.c exits.c build_info.c $(IRI_OBJ)                    \
+              css-url.h css-tokens.h connect.h convert.h cookies.h       \
               ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h      \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
               options.h progress.h ptimer.h recur.h res.h retr.h         \
-              spider.h ssl.h sysdep.h url.h utils.h wget.h
+              spider.h ssl.h sysdep.h url.h utils.h wget.h iri.h         \
+              exits.h gettext.h
 nodist_wget_SOURCES = version.c
-EXTRA_wget_SOURCES = mswindows.c
+EXTRA_wget_SOURCES = mswindows.c iri.c
 LDADD = $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
 AM_CPPFLAGS = -I$(top_srcdir)/lib @MD5_CPPFLAGS@
 
@@ -57,8 +62,13 @@ AM_CPPFLAGS = -I$(top_srcdir)/lib @MD5_CPPFLAGS@
 ../md5/libmd5.a:
        cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
 
+build_info.c: $(srcdir)/Makefile.am $(srcdir)/build_info.c.in
+       $(PERL) $(top_srcdir)/build-aux/build_info.pl \
+           $(srcdir)/build_info.c.in > $@
+
 ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
-version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
+version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am \
+    $(top_srcdir)/configure.ac
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@
@@ -72,9 +82,10 @@ version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
            | $(ESCAPEQUOTE) >> $@
 
 check_LIBRARIES = libunittest.a
-libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h
+libunittest_a_SOURCES = $(wget_SOURCES) test.c build_info.c test.h
 nodist_libunittest_a_SOURCES = version.c
 libunittest_a_CPPFLAGS = -DTESTING -I$(top_srcdir)/lib
 libunittest_a_LIBADD = $(LIBOBJS)
+EXTRA_DIST = build_info.c.in
 
-CLEANFILES = *~ *.bak core core.[0-9]* version.c
+CLEANFILES = *~ *.bak core core.[0-9]* build_info.c version.c