]> sjero.net Git - wget/blobdiff - src/Makefile.am
Merge SFLC licensing changes for OpenSSL with tip.
[wget] / src / Makefile.am
index f1049efa40e62a4979859175e8d1c3812423be8f..8d3270150c97d92e5d65849473379bbc2578944b 100644 (file)
 # You should have received a copy of the GNU General Public License
 # along with Wget.  If not, see <http://www.gnu.org/licenses/>.
 
-# In addition, as a special exception, the Free Software Foundation
-# gives permission to link the code of its release of Wget with the
-# OpenSSL project's "OpenSSL" library (or with modified versions of it
-# that use the same license as the "OpenSSL" library), and distribute
-# the linked executables.  You must obey the GNU General Public License
-# in all respects for all of the code used other than "OpenSSL".  If you
-# modify this file, you may extend this exception to your version of the
-# file, but you are not obligated to do so.  If you do not wish to do
-# so, delete this exception statement from your version.
+# Additional permission under GNU GPL version 3 section 7
+
+# If you modify this program, or any covered work, by linking or
+# combining it with the OpenSSL project's OpenSSL library (or a
+# modified version of that library), containing parts covered by the
+# terms of the OpenSSL or SSLeay licenses, the Free Software Foundation
+# grants you additional permission to convey the resulting work.
+# Corresponding Source for a non-source form of such a combination
+# shall include the source code for the parts of OpenSSL used as well
+# as that of the covered work.
 
 #
 # Version: @VERSION@
@@ -56,7 +57,8 @@ version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
 
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h
-libunittest_a_CPPFLAGS = -DTESTING
+nodist_libunittest_a_SOURCES = version.c
+libunittest_a_CPPFLAGS = -DTESTING -I$(top_srcdir)/lib
 libunittest_a_LIBADD = $(ALLOCA) $(LIBOBJS)
 
 CLEANFILES = *~ *.bak core core.[0-9]* version.c