]> sjero.net Git - wget/blobdiff - src/Makefile.am
Rearrange SOURCES order, add gettext.h for dist.
[wget] / src / Makefile.am
index 257ed156f073eef8e269cabdac73628423ffd825..771318df4f8f634571eaa749f3495b8d78ef5361 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007 Free Software Foundation, Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # You should have received a copy of the GNU General Public License
 # along with Wget.  If not, see <http://www.gnu.org/licenses/>.
 
-# In addition, as a special exception, the Free Software Foundation
-# gives permission to link the code of its release of Wget with the
-# OpenSSL project's "OpenSSL" library (or with modified versions of it
-# that use the same license as the "OpenSSL" library), and distribute
-# the linked executables.  You must obey the GNU General Public License
-# in all respects for all of the code used other than "OpenSSL".  If you
-# modify this file, you may extend this exception to your version of the
-# file, but you are not obligated to do so.  If you do not wish to do
-# so, delete this exception statement from your version.
+# Additional permission under GNU GPL version 3 section 7
+
+# If you modify this program, or any covered work, by linking or
+# combining it with the OpenSSL project's OpenSSL library (or a
+# modified version of that library), containing parts covered by the
+# terms of the OpenSSL or SSLeay licenses, the Free Software Foundation
+# grants you additional permission to convey the resulting work.
+# Corresponding Source for a non-source form of such a combination
+# shall include the source code for the parts of OpenSSL used as well
+# as that of the covered work.
 
 #
 # Version: @VERSION@
 #
 
+if IRI_IS_ENABLED
+IRI_OBJ = iri.c
+endif
+
 # The following line is losing on some versions of make!
 DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS     = @LIBS@ @LIBSSL@ @LIBGNUTLS@
+LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBICONV@ @LIBINTL@ @LIBS@
 
 bin_PROGRAMS = wget
-wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c  \
-              ftp-ls.c hash.c host.c html-parse.c html-url.c http.c    \
-              init.c log.c main.c netrc.c progress.c ptimer.c recur.c  \
-              res.c retr.c safe-ctype.c snprintf.c spider.c url.c      \
-              utils.c version.c xmalloc.c                              \
-              config-post.h connect.h convert.h cookies.h              \
-              ftp.h gen-md5.h getopt.h gnu-md5.h hash.h host.h html-parse.h \
-              http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
-              options.h progress.h ptimer.h recur.h res.h retr.h safe-ctype.h \
-              spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
-EXTRA_wget_SOURCES = mswindows.c
-LDADD = $(ALLOCA) $(LIBOBJS)
+wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                \
+              css.l css-url.c \
+              ftp-basic.c ftp-ls.c hash.c host.c html-parse.c html-url.c \
+              http.c init.c log.c main.c netrc.c progress.c ptimer.c     \
+              recur.c res.c retr.c snprintf.c spider.c url.c             \
+              utils.c exits.c $(IRI_OBJ)                                 \
+              css-url.h css-tokens.h connect.h convert.h cookies.h       \
+              ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h      \
+              http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
+              options.h progress.h ptimer.h recur.h res.h retr.h         \
+              spider.h ssl.h sysdep.h url.h utils.h wget.h iri.h         \
+              exits.h gettext.h
+nodist_wget_SOURCES = build_info.c version.c
+EXTRA_wget_SOURCES = mswindows.c iri.c
+LDADD = $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
+AM_CPPFLAGS = -I$(top_srcdir)/lib @MD5_CPPFLAGS@
+
+../lib/libgnu.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
+../md5/libmd5.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
+build_info.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
+       perl $(top_srcdir)/build_info.pl > $@
+
+ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
+version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am \
+    $(top_srcdir)/configure.ac
+       echo '/* version.c */' > $@
+       echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
+       echo '' >> $@
+       echo 'const char *version_string = "@VERSION@"' >> $@
+       -hg log -r . --template='" ({node|short})"\n' 2>/dev/null >> $@
+       echo ';' >> $@
+       echo 'const char *compilation_string = "'$(COMPILE)'";' \
+           | $(ESCAPEQUOTE) >> $@
+       echo 'const char *link_string = "'$(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+       $(AM_LDFLAGS) $(LDFLAGS) $(LIBS) $(wget_LDADD)'";' \
+           | $(ESCAPEQUOTE) >> $@
 
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h
-libunittest_a_CPPFLAGS = -DTESTING
-libunittest_a_LIBADD = $(ALLOCA) $(LIBOBJS)
+nodist_libunittest_a_SOURCES = build_info.c version.c
+libunittest_a_CPPFLAGS = -DTESTING -I$(top_srcdir)/lib
+libunittest_a_LIBADD = $(LIBOBJS)
+EXTRA_DIST = build_info.c.in
 
-CLEANFILES = *~ *.bak core core.[0-9]*
+CLEANFILES = *~ *.bak core core.[0-9]* build_info.c version.c