]> sjero.net Git - wget/blobdiff - src/Makefile.am
Don't invoke hg to set version string.
[wget] / src / Makefile.am
index 6a3e9947c849befd8b8102e0fd74dc1b01534ab3..754a03f29f97f773f12f609a7d42cff8a7f339d7 100644 (file)
@@ -37,7 +37,7 @@ endif
 
 # The following line is losing on some versions of make!
 DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS     = @LIBICONV@ @LIBINTL@ @LIBS@
+LIBS     = @LIBICONV@ @LIBINTL@ @LIBS@ $(LIB_CLOCK_GETTIME)
 
 bin_PROGRAMS = wget
 wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                \
@@ -71,10 +71,7 @@ version.c:  $(wget_SOURCES) ../lib/libgnu.a
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@
-       echo 'const char *version_string = "@VERSION@"' >> $@
-       -hg log -R "$(top_srcdir)" -r . --template='" ({node|short})"\n' \
-           2>/dev/null >> $@
-       echo ';' >> $@
+       echo 'const char *version_string = "@VERSION@";' >> $@
        echo 'const char *compilation_string = "'$(COMPILE)'";' \
            | $(ESCAPEQUOTE) >> $@
        echo 'const char *link_string = "'$(CCLD) $(AM_CFLAGS) $(CFLAGS) \