]> sjero.net Git - wget/blobdiff - src/Makefile.am
Don't invoke hg to set version string.
[wget] / src / Makefile.am
index 1de1ada6b5028d99a7955063bec21a5c60062024..754a03f29f97f773f12f609a7d42cff8a7f339d7 100644 (file)
@@ -1,7 +1,7 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation,
-# Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -37,14 +37,14 @@ endif
 
 # The following line is losing on some versions of make!
 DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBICONV@ @LIBINTL@ @W32LIBS@ @LIBS@
+LIBS     = @LIBICONV@ @LIBINTL@ @LIBS@ $(LIB_CLOCK_GETTIME)
 
 bin_PROGRAMS = wget
 wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                \
               css.l css-url.c \
               ftp-basic.c ftp-ls.c hash.c host.c html-parse.c html-url.c \
               http.c init.c log.c main.c netrc.c progress.c ptimer.c     \
-              recur.c res.c retr.c snprintf.c spider.c url.c             \
+              recur.c res.c retr.c spider.c url.c                        \
               utils.c exits.c build_info.c $(IRI_OBJ)                    \
               css-url.h css-tokens.h connect.h convert.h cookies.h       \
               ftp.h hash.h host.h html-parse.h html-url.h      \
@@ -63,7 +63,7 @@ AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
 build_info.c: $(srcdir)/Makefile.am $(srcdir)/build_info.c.in
        if test -n "$(VPATH)"; then cp "$(srcdir)/build_info.c.in" .; fi
        $(PERL) "$(top_srcdir)/build-aux/build_info.pl" \
-           "$(abs_builddir)/build_info.c"
+           "$(top_builddir)/src/build_info.c"
        if test -n "$(VPATH)"; then rm -f build_info.c.in; fi
 
 ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
@@ -71,10 +71,7 @@ version.c:  $(wget_SOURCES) ../lib/libgnu.a
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@
-       echo 'const char *version_string = "@VERSION@"' >> $@
-       -hg log -R "$(top_srcdir)" -r . --template='" ({node|short})"\n' \
-           2>/dev/null >> $@
-       echo ';' >> $@
+       echo 'const char *version_string = "@VERSION@";' >> $@
        echo 'const char *compilation_string = "'$(COMPILE)'";' \
            | $(ESCAPEQUOTE) >> $@
        echo 'const char *link_string = "'$(CCLD) $(AM_CFLAGS) $(CFLAGS) \