]> sjero.net Git - wget/blobdiff - src/Makefile.am
Making make check win.
[wget] / src / Makefile.am
index f653cbfc51b02fa000d42927ac4ebae60ad29892..709db8acf5e090b325192f2f6866d90626b3650a 100644 (file)
@@ -38,29 +38,26 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c       \
               ftp-ls.c hash.c host.c html-parse.c html-url.c http.c    \
               init.c log.c main.c netrc.c progress.c ptimer.c recur.c  \
               res.c retr.c snprintf.c spider.c url.c   \
-              utils.c version.c xmalloc.c                              \
-              config-post.h connect.h convert.h cookies.h              \
-              ftp.h gen-md5.h gnu-md5.h hash.h host.h html-parse.h \
+              utils.c xmalloc.c                                \
+              connect.h convert.h cookies.h            \
+              ftp.h gen-md5.h hash.h host.h html-parse.h \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
               options.h progress.h ptimer.h recur.h res.h retr.h \
               spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
+nodist_wget_SOURCES = version.c
 EXTRA_wget_SOURCES = mswindows.c
 LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a
 AM_CPPFLAGS = -I$(top_srcdir)/lib
 
-version.c: hg-id
-       printf '%s' 'const char *version_string = "@VERSION@' > $@
-       -HG_ID=$$(cat hg-id); [ "$$HG_ID" ] && printf '%s' " ($${HG_ID})" >> $@
-       printf '%s\n' '";' >> $@
-
-.INTERMEDIATE: hg-id
-.PHONY: hg-id
-hg-id: $(wget_SOURCES) $(LDADD)
-       -( hg id | cut -f 1 -d ' ' ) 2>/dev/null > $@
+version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
+       echo 'const char *version_string = "@VERSION@"' > $@
+       -hg log -r . --template='" ({node|short})"\n' 2>/dev/null >> $@
+       echo ';' >> $@
 
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h
-libunittest_a_CPPFLAGS = -DTESTING
+nodist_libunittest_a_SOURCES = version.c
+libunittest_a_CPPFLAGS = -DTESTING -I$(top_srcdir)/lib
 libunittest_a_LIBADD = $(ALLOCA) $(LIBOBJS)
 
-CLEANFILES = *~ *.bak core core.[0-9]*
+CLEANFILES = *~ *.bak core core.[0-9]* version.c