]> sjero.net Git - wget/blobdiff - src/Makefile.am
Making make check win.
[wget] / src / Makefile.am
index 0c203f5cafc4a84b245f272a8d0f543446fab0a2..709db8acf5e090b325192f2f6866d90626b3650a 100644 (file)
@@ -39,7 +39,7 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c \
               init.c log.c main.c netrc.c progress.c ptimer.c recur.c  \
               res.c retr.c snprintf.c spider.c url.c   \
               utils.c xmalloc.c                                \
-              config-post.h connect.h convert.h cookies.h              \
+              connect.h convert.h cookies.h            \
               ftp.h gen-md5.h hash.h host.h html-parse.h \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
               options.h progress.h ptimer.h recur.h res.h retr.h \
@@ -56,7 +56,8 @@ version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
 
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h
-libunittest_a_CPPFLAGS = -DTESTING
+nodist_libunittest_a_SOURCES = version.c
+libunittest_a_CPPFLAGS = -DTESTING -I$(top_srcdir)/lib
 libunittest_a_LIBADD = $(ALLOCA) $(LIBOBJS)
 
 CLEANFILES = *~ *.bak core core.[0-9]* version.c