]> sjero.net Git - wget/blobdiff - src/Makefile.am
Fix a build error detected MacOS and NetBSD.
[wget] / src / Makefile.am
index a5a6a9cb3c25cb77b96bad8607f11b599a1af93d..6b951988becff448f351cf8b2679c99042109817 100644 (file)
@@ -1,7 +1,7 @@
 # Makefile for `wget' utility
 # Copyright (C) 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003,
-# 2004, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation,
-# Inc.
+# 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -37,11 +37,13 @@ endif
 
 # The following line is losing on some versions of make!
 DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS     = @LIBSSL@ @LIBICONV@ @LIBINTL@ @LIBS@ @W32LIBS@
+LIBS     = @LIBICONV@ @LIBINTL@ @LIBS@ $(LIB_CLOCK_GETTIME)
+
+EXTRA_DIST = css.l css.c css_.c build_info.c.in
 
 bin_PROGRAMS = wget
 wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                \
-              css.l css-url.c \
+              css_.c css-url.c \
               ftp-basic.c ftp-ls.c hash.c host.c html-parse.c html-url.c \
               http.c init.c log.c main.c netrc.c progress.c ptimer.c     \
               recur.c res.c retr.c spider.c url.c                        \
@@ -57,6 +59,7 @@ EXTRA_wget_SOURCES = iri.c
 LDADD = $(LIBOBJS) ../lib/libgnu.a
 AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
 
+
 ../lib/libgnu.a:
        cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
 
@@ -71,21 +74,27 @@ version.c:  $(wget_SOURCES) ../lib/libgnu.a
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@
-       echo 'const char *version_string = "@VERSION@"' >> $@
-       -hg log -R "$(top_srcdir)" -r . --template='" ({node|short})"\n' \
-           2>/dev/null >> $@
-       echo ';' >> $@
+       echo 'const char *version_string = "@VERSION@";' >> $@
        echo 'const char *compilation_string = "'$(COMPILE)'";' \
            | $(ESCAPEQUOTE) >> $@
        echo 'const char *link_string = "'$(CCLD) $(AM_CFLAGS) $(CFLAGS) \
        $(AM_LDFLAGS) $(LDFLAGS) $(LIBS) $(wget_LDADD)'";' \
            | $(ESCAPEQUOTE) >> $@
 
+css.c: $(srcdir)/css.l
+       $(LEX) $(LFLAGS) -o $@ $^
+
+css_.c: css.c
+       echo '#include "wget.h"' > $@
+       cat css.c >> $@
+
+distclean-local:
+       rm -f css.c css_.c
+
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c build_info.c test.h
 nodist_libunittest_a_SOURCES = version.c
 libunittest_a_CPPFLAGS = -DTESTING "-I$(top_builddir)/lib" "-I$(top_srcdir)/lib"
 libunittest_a_LIBADD = $(LIBOBJS)
-EXTRA_DIST = build_info.c.in
 
 CLEANFILES = *~ *.bak core core.[0-9]* build_info.c version.c