]> sjero.net Git - wget/blobdiff - src/Makefile.am
Fixes for when IRIs are disabled.
[wget] / src / Makefile.am
index a225e8f692051ab597cd8001a82a643eee1e6afc..523f1957bc6a312e8d8257ef0ce09ee34eab6a25 100644 (file)
@@ -36,7 +36,7 @@ endif
 
 # The following line is losing on some versions of make!
 DEFS     = @DEFS@ -DSYSTEM_WGETRC=\"$(sysconfdir)/wgetrc\" -DLOCALEDIR=\"$(localedir)\"
-LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBINTL@ @LIBS@
+LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBICONV@ @LIBINTL@ @LIBS@
 
 bin_PROGRAMS = wget
 wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                \
@@ -49,9 +49,9 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c               \
               ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h      \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
               options.h progress.h ptimer.h recur.h res.h retr.h         \
-              spider.h ssl.h sysdep.h url.h utils.h wget.h
+              spider.h ssl.h sysdep.h url.h utils.h wget.h iri.h
 nodist_wget_SOURCES = build_info.c version.c
-EXTRA_wget_SOURCES = mswindows.c
+EXTRA_wget_SOURCES = mswindows.c iri.c
 LDADD = $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
 AM_CPPFLAGS = -I$(top_srcdir)/lib @MD5_CPPFLAGS@