]> sjero.net Git - wget/blobdiff - src/Makefile.am
Dependency improvements (but still needs some work).
[wget] / src / Makefile.am
index c8485cfd8125d3877160f990d1a805aa02ee10d2..441cfa1b3a3310aa631c752d36a8a47d993b4bab 100644 (file)
@@ -36,12 +36,13 @@ LIBS     = @LIBSSL@ @LIBGNUTLS@ @LIBINTL@ @LIBS@
 
 bin_PROGRAMS = wget
 wget_SOURCES = build_info.c cmpt.c connect.c convert.c cookies.c ftp.c    \
+              css.l css-url.c \
               ftp-basic.c ftp-ls.c hash.c host.c html-parse.c html-url.c \
               http.c init.c log.c main.c netrc.c progress.c ptimer.c     \
               recur.c res.c retr.c snprintf.c spider.c url.c             \
               utils.c                                    \
-              connect.h convert.h cookies.h                              \
-              ftp.h gen-md5.h hash.h host.h html-parse.h                 \
+              css-url.h connect.h convert.h cookies.h \
+              ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h      \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
               options.h progress.h ptimer.h recur.h res.h retr.h         \
               spider.h ssl.h sysdep.h url.h utils.h wget.h
@@ -50,17 +51,25 @@ EXTRA_wget_SOURCES = mswindows.c
 LDADD = $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
 AM_CPPFLAGS = -I$(top_srcdir)/lib @MD5_CPPFLAGS@
 
+../lib/libgnu.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
+../md5/libmd5.a:
+       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
+
 ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
 version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@
-       echo -n 'char* version_string = "@VERSION@ ' >> $@
-       -hg log -r . --template=' ({node|short})"\n' 2>/dev/null >> $@
+       echo -n 'const char *version_string = "@VERSION@"' >> $@
+       -hg log -r . --template='" ({node|short})"\n' 2>/dev/null >> $@
        echo ';' >> $@
-       echo 'char* compilation_string = "'$(COMPILE)'";' | $(ESCAPEQUOTE) >> $@
-       echo 'char* link_string = "'$(CCLD) $(AM_CFLAGS) $(CFLAGS) \
-       $(AM_LDFLAGS) $(LDFLAGS) $(LIBS) $(wget_LDADD)'";' | $(ESCAPEQUOTE) >> $@
+       echo 'const char *compilation_string = "'$(COMPILE)'";' \
+           | $(ESCAPEQUOTE) >> $@
+       echo 'const char *link_string = "'$(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+       $(AM_LDFLAGS) $(LDFLAGS) $(LIBS) $(wget_LDADD)'";' \
+           | $(ESCAPEQUOTE) >> $@
 
 check_LIBRARIES = libunittest.a
 libunittest_a_SOURCES = $(wget_SOURCES) test.c test.h