]> sjero.net Git - wget/blobdiff - src/Makefile.am
Use gnulib's MD5.
[wget] / src / Makefile.am
index e508ceeba3b28665c224c8772fe7e07449b7194b..361de3c70ca9cdc635b8248d6a4961a8470c4d18 100644 (file)
@@ -37,15 +37,16 @@ bin_PROGRAMS = wget
 wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c ftp-basic.c  \
               ftp-ls.c hash.c host.c html-parse.c html-url.c http.c    \
               init.c log.c main.c netrc.c progress.c ptimer.c recur.c  \
-              res.c retr.c safe-ctype.c snprintf.c spider.c url.c      \
+              res.c retr.c snprintf.c spider.c url.c   \
               utils.c version.c xmalloc.c                              \
               config-post.h connect.h convert.h cookies.h              \
-              ftp.h gen-md5.h getopt.h gnu-md5.h hash.h host.h html-parse.h \
+              ftp.h gen-md5.h hash.h host.h html-parse.h \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h \
-              options.h progress.h ptimer.h recur.h res.h retr.h safe-ctype.h \
+              options.h progress.h ptimer.h recur.h res.h retr.h \
               spider.h ssl.h sysdep.h url.h utils.h wget.h xmalloc.h
 EXTRA_wget_SOURCES = mswindows.c
-LDADD = $(ALLOCA) $(LIBOBJS)
+LDADD = $(ALLOCA) $(LIBOBJS) ../lib/libgnu.a
+AM_CPPFLAGS = -I$(top_srcdir)/lib
 
 version.c: hg-id
        printf '%s' 'const char *version_string = "@VERSION@' > $@
@@ -53,6 +54,7 @@ version.c: hg-id
        printf '%s\n' '";' >> $@
 
 .INTERMEDIATE: hg-id
+.PHONY: hg-id
 hg-id: $(wget_SOURCES) $(LDADD)
        -( hg id | cut -f 1 -d ' ' ) 2>/dev/null > $@