]> sjero.net Git - wget/blobdiff - src/Makefile.am
Use the gnulib md5 module.
[wget] / src / Makefile.am
index 45bbf8655ed8676f1cce7ec667a111991a81c144..1de1ada6b5028d99a7955063bec21a5c60062024 100644 (file)
@@ -47,23 +47,19 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c                     \
               recur.c res.c retr.c snprintf.c spider.c url.c             \
               utils.c exits.c build_info.c $(IRI_OBJ)                    \
               css-url.h css-tokens.h connect.h convert.h cookies.h       \
-              ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h      \
+              ftp.h hash.h host.h html-parse.h html-url.h      \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
               options.h progress.h ptimer.h recur.h res.h retr.h         \
               spider.h ssl.h sysdep.h url.h utils.h wget.h iri.h         \
               exits.h gettext.h
 nodist_wget_SOURCES = version.c
 EXTRA_wget_SOURCES = iri.c
-LDADD = $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
-AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib @MD5_CPPFLAGS@
-MD5_LDADD = @MD5_LDADD@
+LDADD = $(LIBOBJS) ../lib/libgnu.a
+AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
 
 ../lib/libgnu.a:
        cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
 
-../md5/libmd5.a:
-       cd ../lib && $(MAKE) $(AM_MAKEFLAGS)
-
 build_info.c: $(srcdir)/Makefile.am $(srcdir)/build_info.c.in
        if test -n "$(VPATH)"; then cp "$(srcdir)/build_info.c.in" .; fi
        $(PERL) "$(top_srcdir)/build-aux/build_info.pl" \
@@ -71,7 +67,7 @@ build_info.c: $(srcdir)/Makefile.am $(srcdir)/build_info.c.in
        if test -n "$(VPATH)"; then rm -f build_info.c.in; fi
 
 ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
-version.c:  $(wget_SOURCES) ../lib/libgnu.a $(MD5_LDADD)
+version.c:  $(wget_SOURCES) ../lib/libgnu.a
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@