]> sjero.net Git - wget/blobdiff - src/Makefile.am
Improved exit status handling.
[wget] / src / Makefile.am
index 523f1957bc6a312e8d8257ef0ce09ee34eab6a25..026ff1c8da221676873d590201ebbd904951092c 100644 (file)
@@ -49,7 +49,8 @@ wget_SOURCES = cmpt.c connect.c convert.c cookies.c ftp.c               \
               ftp.h gen-md5.h hash.h host.h html-parse.h html-url.h      \
               http.h http-ntlm.h init.h log.h mswindows.h netrc.h        \
               options.h progress.h ptimer.h recur.h res.h retr.h         \
-              spider.h ssl.h sysdep.h url.h utils.h wget.h iri.h
+              spider.h ssl.h sysdep.h url.h utils.h wget.h iri.h         \
+              exits.c exits.h
 nodist_wget_SOURCES = build_info.c version.c
 EXTRA_wget_SOURCES = mswindows.c iri.c
 LDADD = $(LIBOBJS) ../lib/libgnu.a @MD5_LDADD@
@@ -65,7 +66,8 @@ build_info.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
        perl $(top_srcdir)/build_info.pl > $@
 
 ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'
-version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am
+version.c:  $(wget_SOURCES) $(LDADD) $(srcdir)/Makefile.am \
+    $(top_srcdir)/configure.ac
        echo '/* version.c */' > $@
        echo '/* Autogenerated by Makefile - DO NOT EDIT */' >> $@
        echo '' >> $@